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Abstract

KDE is an international technology team that creates Free Software for desktop and portable
computing. Among KDE’s products are a modern desktop system for Linux® and UNIX®

platforms, comprehensive office productivity and groupware suites and hundreds of software
titles in many categories including Internet and web applications, multimedia, entertainment,
educational, graphics and software development.

https://www.gnu.org/philosophy/free-sw.html
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Chapter 1

KDE Help System Handbook

1.1 Help System

The help system is designed to make accessing the common UNIX® help systems (man and info)
simple, as well as the user documentation of applications including KDE Plasma Workspaces
from the KDE community (XML).

All applications (including KDE Plasma Workspaces) from the KDE community come fully doc-
umented, thanks to the efforts of the Documentation team. If you are interested in helping with
the documentation efforts, join the mailing list and write to the team at kde-doc-english@kde.org.
No experience is required, just enthusiasm and patience.

If you would like to help translating KDE documentation to your native language, review the
information, including coordinators for each language team, on the Localization web site.

1.2 Invoking Help

KHelpCenter can be called in several ways:

From the Help menu

The most common will probably be from within an application. Choose Help → Applica-
tion Handbook (F1) to open that application’s handbook.

From the Application Launcher

Choose the big K in your panel, and select Help from the Applications tab or type help
followed by selecting Help. This will open KHelpCenter with the default start page.

From the command line
KHelpCenter may be started using a URL to display a file. URLs have been added for info
and man pages also. You can use them as follows:

An application help file
khelpcenter help:/ kwrite
Opens the KWrite help file, at the contents page.

A local URL
khelpcenter file:/ usr/local/src/qt/html/index.html
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A Man page
khelpcenter man:/ strcpy

An Info page
khelpcenter info:/ gcc

Invoking khelpcenter with no parameters opens the default start page.

1.3 The KHelpCenter interface

The KHelpCenter interface consists of two panes of information.

The toolbar and menus are explained further in Section 1.3.4.

Documents contain their own navigation tools, enabling you to move either sequentially through
a document, using Next, Previous, and Contents links, or to move around in a less structured
manner, using hyperlinks.

Links can take you to other parts of the same document, or to a different document, and you
can use the Back (Left pointing arrow) or Forward (Right pointing arrow) icons on the toolbar to
move through the documents you have viewed in this session.

The two panes display the contents of the help system, and the help files themselves, on the left
and right respectively.

1.3.1 The Contents Pane

The contents pane in KHelpCenter is displayed on the left hand side of the window. As you
might expect, you can move the splitter bar, to make sure you can comfortably read the contents
of either pane.

The contents pane is further divided into three tabs, one containing a tree view showing all the
help information KHelpCenter is aware of, and the other contains the KDE glossary of terms. On
the third tab you can configure the Search Options.

1.3.1.1 The Contents Tab

The Contents tab contains the following default top level entries in the tree view:

Fundamentals
The Fundamentals introduce you to the many features of the KDE Plasma Workspaces and
Applications and describe many common tasks you can perform in all Applications.

Plasma Manual
The Plasma Manual is the documentation for the KDE Plasma Workspaces.

Online Help

A page with links to online help and additional information provided by the KDE commu-
nity.

Application Manuals

Native KDE application documentation. All KDE applications have documentation in XML
format, which are converted to HTML when you view them. This section lists all the KDE
applications with a brief description and a link to the full application documentation.
The applications are displayed in a tree structure that echoes the default structure of the K
menu, making it easy to find the application you are looking for.
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Settings Modules entities

Provide a list of links to various modules in the System Settings application or to modules
for Konqueror, Filemanager or Browser.

KInfoCenter Modules
Contains a list of links to various KInfocenter modules documentation.

KIO Workers
Contains a list of links to various KIO modules documentation.

UNIX® manual pages

UNIX® man pages are the traditional on-line documentation format for UNIX® systems.
Most programs on your system will have a man page. In addition, man pages exist for
programming functions and file formats.

Scrollkeeper

Additional non-KDE documentation installed on your system.

Browse Info Pages

TeXinfo documentation is used by many GNU applications, including gcc (the C/C++ com-
piler), emacs, and many others.

1.3.1.2 The Search Options tab

Searching the help files is fairly intuitive, enter the word(s) you wish to search for in the text box,
choose your options (if any), and press Search. The results display in the viewer pane to the
right.

NOTE
Search is not case sensitive, i.e. uppercase and lowercase characters are considered the same. For
example, if you search for ‘Shortcut’, results that contain ‘shortcut’ will be returned as well.

The options available are:

Method
Choose how to search for multiple words. If you choose and, results are returned only if all
your search terms are included in the page. or returns results if any of the search terms are
found.
If your searches are not returning the results you expect, check carefully you haven’t ex-
cluded the wrong search term with an erroneous setting.

Max. results
Determines the maximum number of results returned from your search.

Scope selection

This is used to select the sections where the search will be done. The available options
quickly select the most common option, while Custom allows one to select single sections.
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1.3.2 The Man and Info sections

Man pages are the standard UNIX® manual pages, and have been in use for many years on many
operating systems. They are extremely thorough, and are the very best place to get information
about most UNIX® commands and applications. When people say ‘RTFM’, the Manual they are
referring to is very often the man page.

The man pages are not perfect. They tend to be in depth, but also extremely technical, often
written by developers, and for developers. In some cases this makes them somewhat unfriendly,
if not downright impossible for many users to understand. They are, however, the best source of
solid information on most command line applications, and very often the only source.

If you’ve ever wondered what the number is when people write things like man(1) it means
which section of the manual the item is in. You will see KHelpCenter uses the numbers to divide
the very many man pages into their own sections, making it easier for you to find the information
you’re looking for, if you’re just browsing.

Also available are the Info pages, intended to be a replacement for the man pages. The maintainer
of some applications no longer update the man pages, so if there is both a man page and an info
page available, the info page is probably the most recent. Most applications have one or the other
though. If the application you are looking for help on is a GNU utility, you will most likely find
it has an info page, not a man page.

1.3.2.1 Navigating inside the Info pages

Info documents are arranged hierarchically with each page called a node. All info documents
have a Top node, i.e. the opening page. You can return to the Top of an info document by
pressing Top.

Prev & Next are used to move to the previous/next page at the current level of the hierarchy.

Clicking on a menu item within a document moves you to a lower level in the hierarchy. You
may move up the hierarchy by pressing Up.

Man is treated similarly to info, with the section index being the Top node and each man page on
the level below. Man entries are one page long.

1.3.3 The KDE glossary

The glossary provides a quick reference point, where you can look up the definitions of words
that may be unfamiliar to you. These range from KDE specific applications and technologies,
through to general UNIX® computing terms.

In the left hand pane you will see a tree view, with two choices: Alphabetically or By Topic. Both
contain the same entries, sorted differently, to allow you to quickly find the item of interest.

Navigate down the tree views to the left, and items you select will be displayed on the right.

1.3.4 The menus and toolbar

KHelpCenter has a very minimal interface, allowing you to concentrate on getting help rather
than learning how to use the help browser.

The icons available to you in the toolbar are as follows:

TOOLBAR ICONS

Table of Contents
Go to the main start page of KHelpCenter.
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Back
Go to the previous page you viewed. Click the check mark right to the icon. This displays
a list of previously viewed pages. Selecting one will take you directly back to that page.

Forward
Go forward one page. This icon is only active if you have already used the Back icon.

Copy

Copy text to the clipboard to be pasted in another application.

Find
Find a word or words within the currently visible page.

Increase Font Sizes
Increase the size of the text in the viewer pane.

Decrease Font Sizes
Decrease the size of the text in the viewer pane. This icon is only enabled if you have
previously enlarged the text.

The menus contain the following entries:

File

File → Print (Ctrl+P)
Print the contents of the currently visible page. Handbooks in PDF format you find
on the KDE Documentation Server.

File → Quit (Ctrl+Q)
Close and exit KHelpCenter

Edit

Edit → Copy (Ctrl+C)
Copy the selected text to the clipboard.

Edit → Select All (Ctrl+A)
Select all the text in the current page.

Edit → Find... (Ctrl+F)
Find a word or words in the currently visible page.

View

View → Set Encoding
Change the encoding of the current page. Normally, the default setting of Default
should be sufficient, but if you are having problems viewing pages written in lan-
guages other than English, you may need to choose a specific encoding in this menu.

View → Full Screen Mode
Changes KHelpCenter to full screen mode, in which the KHelpCenter window takes
up the whole screen, and does not have the usual window decorations. To exit full
screen mode, press Ctrl+Shift+F.

Go
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Go → Table of Contents (Alt+Home)
Go to the main start page of KHelpCenter.

Go → Previous Page (Ctrl+PgUp)
Go to the previous page of the current documentation.

Go → Next Page (Ctrl+PgDown)
Go to the next page of the current documentation.

Go → Back (Alt+Left)
Go back to the previous page you were viewing.

Go → Forward (Alt+Right)
If you have previously moved back with the back icon or menu entry, you can work
your way forward again with this menu entry.

Bookmarks

Bookmarks → Add Bookmark (Ctrl+B)
Add a bookmark for the current page, the title of the pages is appended to the book-
marks menu. Use the action Delete Bookmark in the context menu of an item to
remove it from the menu.

Bookmarks → New Bookmarks Folder
Open the New Folder dialog where you can add new submenuitems to the book-
marks menu.

Settings

Settings → Configure Fonts...
Allows you to configure the font family and size used by KHelpCenter.

Additionally KHelpCenter has the common KDE Settings and Help menu items, for more infor-
mation read the sections about the Settings Menu and Help Menu of the KDE Fundamentals.

1.4 Credits and License

KHelpCenter

Originally developed by Matthias Elter elter@kde.org

The current maintainer is Cornelius Schumacher schumacher@kde.org

This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.
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