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Abstract

KWordQuiz is a flashcard and vocabulary learning program by KDE.
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Chapter 1

Introduction

KWordQuiz is a tool that gives you a powerful way to master new vocabularies. It may be a
language or any other kind of terminology.

1.1 Easy to use

With KWordQuiz you build your own vocabulary documents in a simple and intuitive way. The
basic layout is a two-column spreadsheet where you type vocabulary entries in one form that
you know and in another form that you want to learn. You change the titles of the columns to
reflect what you are practicing.

1.1.1 Practice modes

Before you start a quiz you select how you want to practice. KWordQuiz offers five different
modes to make practicing more efficient. The different modes make it possible to have the quiz
go through your vocabulary in sequential or random order in one or both directions.

1.1.2 Quiz types

When you have entered your vocabulary and selected a mode, you are ready to start a quiz.
Maybe you want to start with a flashcard session. Later you can move on to a multiple choice
quiz, or do the powerful question and answer quiz. You get instant feedback on correct and
incorrect answers, and you have the option to repeat any errors, further improving your learning
efficiency. If you need a little extra help you can use the hint function.

1.1.3 Vocabulary documents

KWordQuiz can open several types of vocabulary data. The default format is .kvtml, a file format
shared by several KDE programs. KWordQuiz should also open .wql files created by KWordQuiz
for Windows®, .csv files with comma separated text, .voc files created by the old version of
Vokabeltrainer, .xdxf files, and .xml.gz files created by the old versions of Pauker.

KWordQuiz can save your vocabulary documents in several different formats. The default is the
.kvtml format used by other KDE programs. Another available option is comma separated text
.csv.
You can have several files open at the same time, and easily copy or move entries between files.
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Chapter 2

Command Reference

2.1 The File Menu

File → New (Ctrl+N)
New creates a new blank vocabulary document

File → Open... (Ctrl+O)

Open one or more existing vocabulary documents.

File → Open Recent

Open a recently used vocabulary document.

File → Download New Vocabularies... (Ctrl+G)
Downloads new vocabularies. Downloaded vocabularies can be found in the $XDG_DATA_
HOME/kvtml folder. $XDG_DATA_HOME is usually a hidden folder in your Home folder called
.local.

File → Save (Ctrl+S)
Save the active vocabulary document to disk.

File → Save As... (Ctrl+Shift+S)
Save the active vocabulary document with a new name.

File → Print... (Ctrl+P)
Print the active vocabulary document. KWordQuiz provides several options for printing
your vocabularies.

File → Print Preview
Show preview of the active vocabulary document printed by KWordQuiz.

File → Close (Ctrl+W)
Close the active vocabulary document.

File → Quit (Ctrl+Q)
Quit KWordQuiz
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2.2 The Edit Menu

Edit → Undo (Ctrl+Z)
Undo the last command. The name of this item will change to reflect what will be undone.

Edit → Redo (Ctrl+Shift+Z)
Redo the last command. The name of this item will change to reflect what will be redone.

Edit → Cut (Ctrl+X)
Cut the current selection and place it on the clipboard.

Edit → Copy (Ctrl+C)

Copy the current selection and place it on the clipboard.

Edit → Paste (Ctrl+V)
Paste the content of the clipboard to the current selection. If only one cell is selected
KWordQuiz will activate smart pasting and calculate the space required for pasting and
add rows if necessary.

Edit → Clear (Del)
Clear the current selection.

Edit → Insert Row (Ctrl+I)
Insert a new row at the current selection. If the selection extends over more than one row,
an equal number of rows will be inserted.

Edit → Delete Row (Ctrl+K)
Delete the selected row. If the selection extends over more than one row, all selected rows
will be deleted.

Edit → Mark as Blank (Ctrl+M)
Mark as Blank marks selected text (or the word where the caret is) as a blank for a ’Fill-in-
the-blank’ quiz, i.e., it’s enclosed in brackets. Only available if Fill-in-the-blank is enabled.

Edit → Unmark Blanks
Unmark Blanks clears previously assigned blanks, i.e., brackets are removed. Only avail-
able if Fill-in-the-blank is enabled.

2.3 The Vocabulary Menu

Vocabulary → Column Settings... (Ctrl+L)

Define the titles, the keyboard layouts, and the widths of the two columns in the vocabulary.
Displays a dialog.

Vocabulary → Font...

Change the font used to display the vocabulary.

Vocabulary → Link Image...

Specify the image that should be linked with the current entry.

Vocabulary → Link Sound...

Specify the sound that should be linked with the current entry.
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Vocabulary → Adjust Row Heights

Adjust the height of the rows to fit the content.

Vocabulary → Shuffle

Shuffle the vocabulary entries in a random order. The order of the entries in the actual
vocabulary document is not changed.

2.4 The Mode Menu

The menu provides five different modes for the quiz.

NOTE
The menu names will change to reflect the column titles of the currently active vocabulary document.
The mode must be selected before a quiz is started. The selected mode will apply to Flashcard,
Multiple Choice and Question & Answer.

Mode → 1 Column 1 -> Column 2 In Order
During the quiz you will be given the entries of Column 1 and asked to provide the cor-
responding Column 2 entries. This will be done in the order the entries appear in the
vocabulary document.

Mode → 2 Column 2 -> Column 1 In Order
During the quiz you will be given the entries of Column 2 and asked to provide the cor-
responding Column 1 entries. This will be done in the order the entries appear in the
vocabulary document.

Mode → 3 Column 1 -> Column 2 Randomly

During the quiz you will be given the entries of Column 1 and asked to provide the cor-
responding Column 2 entries. This will be done in a random order, but each entry will be
processed once.

Mode → 4 Column 2 -> Column 1 Randomly

During the quiz you will be given the entries of Column 2 and asked to provide the cor-
responding Column 1 entries. This will be done in random order, but each entry will be
processed once.

Mode → 5 Column 1 <-> Column 2 Randomly

During the quiz you will be given an entry of either Column 1 or Column 2 and asked to
provide the corresponding entry in the other column. This will be done in a random order
for both column and entry. Each possible combination will be processed once.

2.5 The Quiz Menu

Quiz → Check (Return)
Check if your answer is correct

Quiz → I Know (K)
Count as correct during a flashcard session.
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Quiz → I Do Not Know (D)
Count as error during a flashcard session. You can later repeat these cards by selecting Quiz
→ Repeat Errors.

Quiz → Hint (Ctrl+H)
Get the next correct letter during a Question & Answer session.

Quiz → Play Audio (Ctrl+B)

Play sound that was linked to the entry with Vocabulary → Link Sound.

Quiz → Restart (Ctrl+R)
Restart the quiz session from the beginning. This will reset the scores.

Quiz → Repeat Errors (Ctrl+E)

Repeat any questions you answered incorrectly. This becomes available once you have
answered all the questions once.

Quiz → Export Errors As...

Export any questions you answered incorrectly as a new vocabulary document. This be-
comes available once you have answered all the questions once.

2.6 The Settings and Help Menu

Apart from the common KDE Settings and Help menu items described in the Settings Menu and
Help Menu of the KDE Fundamentals KWordQuiz this additional menu entry is provided:

Settings → Show Search

Toggle display of the search bar.
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Chapter 3

The Main Window

The main window has a navigation panel on the left side from which the main components of
the program can be activated.

The editor can be activated by pressing (F6).

A flashcard session can be started by pressing (F7).

A multiple choice session can be started by pressing (F8).

A question and answer session can be started by pressing (F9).
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Chapter 4

The Vocabulary Editor

The vocabulary document area has the appearance of a spreadsheet-like grid. The grid consists
of cells organized in two columns and a number of rows. Each column and row has a header.
The column headers are used to specify the titles of the vocabulary document. They can be set by
selecting Vocabulary → Column Settings.... The row headers number the rows consecutively.

The column headers can also be used to sort the vocabulary. Simply click on the header of the
column you want to sort by.

You can click in a cell of the grid to make it the active cell. You can select several cells for copying
or other editing by dragging over them with the left mouse button down. To select entire rows
click in the header.

In the document, you build a vocabulary of pair-wise entries in the two columns. You can enter
text into the active cell simply by starting to type. The cell will now be in edit mode and you can
select all or part of the text. You can also edit a cell by double-clicking it or by pressing F2 and
making changes directly in the cell.

When you have finished typing one entry, press the return key and the next cell will automatically
become active. Hence, it’s easy to quickly type several entries. You can customize this behavior
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by selecting Settings → Configure KWordQuiz.... When you reach the bottom row of the grid,
a new row will be added as you press return, so you can just continue to type. When a new
window is created it has 20 rows, but there is really no limit to the number of rows you can have
in a document.
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Chapter 5

Flashcard Session

Select Flashcard from the navigation panel to start a flashcard session on the entries of the active
vocabulary document. The mode selected in the Mode menu will be used. If you change mode
during a session, the session will be restarted.

If you are working with long expressions, the window can be resized to make more space avail-
able. The font size will also influence how much will fit in the different parts of the window.
By selecting Settings → Configure KWordQuiz... you can configure the appearance of the flash-
cards.

Initially the front of the card is displayed. Use Quiz → Check to see the other side.

To move on to the next card, either select Quiz → I Know to count the card as correct or Quiz
→ I Don’t Know to count the card as incorrect.
Select Quiz → Repeat Errors to repeat the cards you have counted as incorrect.

Select Quiz → Restart to start the session from the beginning again. If you are using a random
mode the cards will be reshuffled.
The score section at the bottom of the screen shows the number of cards, the number of cards you
have seen, the number of cards counted as correct, and the number counted as incorrect.
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TIP
All items on the Quiz menu are available on the Quiz toolbar that is displayed on the right by default.
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Chapter 6

Multiple Choice Session

Select Multiple Choice from the navigation panel to start a multiple choice quiz on the entries
in the active vocabulary document. The mode selected in the Mode menu will be used. If you
change mode during a session, the session will be restarted.

If you are working with long expressions the window can be resized to make more room. The
font size (selected for the editor) will also influence how much will fit in the different parts of the
window.
In the example below the user gave an incorrect answer to the previous question. He/she is now
about to answer the next question.

Your choices are shown on the top left. Select the one you think is correct. Use Quiz → Check to
see if the answer is correct. If you have activated the automatic mode in Settings → Configure
KWordQuiz... your selection is checked immediately.

The previous question is shown below the current one. The answer you gave is also displayed.
If you answered incorrectly the correct answer is shown.

Select Quiz → Repeat Errors to repeat the questions you answered incorrectly.
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Select Quiz → Restart to start the session from the beginning again. If you are using a random
mode the questions will be reshuffled.

The score section at the bottom of the screen shows the number of questions, the number of ques-
tions you have answered, the number of correct answers, and the number of incorrect answers.

TIP
All items on the Quiz menu are available on the Quiz toolbar that is displayed on the right by default.

16



The KWordQuiz Handbook

Chapter 7

Question & Answer Session

Select Question & Answer from the navigation panel to start a question & answer session on the
entries in the active vocabulary. The mode selected in the Mode menu will be used. If you change
mode during a session, the session will be restarted.

If you are working with long expressions, the window can be resized to make more room. The
font size (selected for the editor) will also influence how much will fit in the different parts of the
window.
In the example below the user gave a correct answer to the previous question (to see how incor-
rect answers are handled, see the Multiple Choice chapter). He/she is now about to answer the
next question.

Your question is shown on the top left. Type your answer in the edit field. Use Quiz → Check or
Enter to see if the answer is correct.
The previous question is shown below the current one. The answer you gave is also displayed.
If you answered incorrectly the correct answer is shown.

Select Quiz → Hint to get the next correct letter of the answer. In Settings → Configure
KWordQuiz... you may choose to count any questions where you use the hint function as in-
correct.
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Select Quiz → Repeat Errors to repeat the questions you answered incorrectly.

Select Quiz → Restart to start the session from the beginning again. If you are using a random
mode the questions will be reshuffled.

The score section at the bottom of the screen shows the number of questions, the number of ques-
tions you have answered, the number of correct answers, and the number of incorrect answers.

TIP
All items on the Quiz menu are available on the Quiz toolbar that is displayed on the right by default.

18



The KWordQuiz Handbook

Chapter 8

Fill-in-the-blank

’Fill-in-the-blank’ is a powerful way to practice in KWordQuiz. It is a special kind of question
and answer quiz that needs to be described in more detail. In order to use this feature you must
turn it on in the configuration dialog.

Consider the following table. It could be a vocabulary in KWordQuiz:

English German

1 We own a computer Wir besitzen einen
Computer

2 We own a computer Wir [besitzen] einen
Computer

3 We own a computer Wir [besitzen einen]
Computer

4 We own a computer Wir [besitzen] einen
[Computer]

The important thing to note is the placement of the brackets. They tell KWordQuiz how the quiz
should be performed.

In 1. there are no brackets. Assuming English is the question and German the answer you have
to give the entire expression ’Wir besitzen einen Computer’ for a correct answer.

In 2. KWordQuiz would display the question but also ’Wir ........ einen Computer’. For a correct
answer it is sufficient to write ’besitzen’.
3. shows that a blank can consist of more than one word. The correct answer is ’besitzen einen’.
In 4. there are two separate blanks. To specify that in the answer you have to write ’besitzen;
Computer’, i.e. separate the blanks with a semicolon in order to get a correct answer.

Marked blanks are only of relevance if they appear in the answer. Otherwise the brackets are
ignored. Furthermore, brackets have no effect in multiple choice quizzes. To simplify the creation
of ’Fill-in-the-blank’ vocabularies there are menu commands to mark and unmark blanks. Of
course you can also just type the brackets. KWordQuiz checks the syntax. If the text appears in
red there is something wrong with the brackets and a quiz cannot be started.

The ’Fill-in-the-blank’ features can be turned on and off in the Configuration dialog. Turning
them off will make it possible to use fonts that map other characters to the positions of the brack-
ets. It will also speed up performance slightly.
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Chapter 9

Printing

KWordQuiz provides the ability to print vocabulary documents in several different ways. When
selecting File → Print... you are presented with the standard KDE print dialog. In order to get
access to the special KWordQuiz features you need to click on the Options » to see the Vocab-
ulary Options tab. On this tab you can select to print the document as a vocabulary list (i.e. as
displayed in the editor), a vocabulary exam, or as flashcards.

Vocabulary list The vocabulary will be printed as displayed in the editor. This includes font, row
heights, and column widths. Make sure that the columns are narrow enough to fit on the page.
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Vocabulary exam The vocabulary will be printed as displayed in the editor, except that the right
column will be left empty and a third column for scoring is added. Settings used include font,
row heights, and column widths. Make sure that the columns are narrow enough to fit on the
page.

Flashcards Two 3˝ x 5˝ cards per page. The cards will always be printed in landscape.
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Chapter 10

Dialogs

10.1 General Settings

You can select what type of session a newly opened vocabulary should start in. Going directly to
a quiz can prevent you from seeing any entries in advance.

Select Defaults to restore all settings to predefined defaults. Select Apply to make your changes
without closing the dialog. Select OK to make your changes and close the dialog. Select Cancel
to close the dialog without making any changes.
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10.2 Editor Settings

You can configure the behavior of the Enter key when working in the editor.

You can also select if the functions for Fill-in-the-blank should be activated. Turning them off will
speed up performance a little.

Select Defaults to restore all settings to predefined defaults. Select Apply to make your changes
without closing the dialog. Select OK to make your changes and close the dialog. Select Cancel
to close the dialog without making any changes.
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10.3 Quiz Settings

For flashcard sessions you can select if the cards should be flipped automatically, and if they
should be counted as correct or incorrect. Enter a time delay in seconds for the automatic flipping.

For multiple choice sessions you can select if your choice should be checked immediately or if
you have to select Quiz → Check first.

For question & answer sessions you can select if questions where you use Quiz → Hint should
be counted as incorrect.
For all sessions you can select if the scores should be displayed as percentages instead of absolute
numbers.
Select Defaults to restore all settings to predefined defaults. Select Apply to make your changes
without closing the dialog. Select OK to make your changes and close the dialog. Select Cancel
to close the dialog without making any changes.
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10.4 Flashcard Appearance Settings

For flashcard sessions you can select the Font: and the colors of text, cards, and frames. Click the
Flip card button to switch between the Front and the Back of the cards.

Select Defaults to restore all settings to predefined defaults. Select Apply to make your changes
without closing the dialog. Select OK to make your changes and close the dialog. Select Cancel
to close the dialog without making any changes.
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10.5 Special Characters Settings

Nine configurable actions are available for insertion of special characters into the vocabulary.
Select one of the actions in the list and then click the Character... button to select a character for
that action. A larger preview of the current character is displayed.

Changing the keyboard shortcut associated with each action can be done by selecting Settings
→ Configure Shortcuts....

Select Defaults to restore all settings to predefined defaults. Select Apply to make your changes
without closing the dialog. Select OK to make your changes and close the dialog. Select Cancel
to close the dialog without making any changes.

10.6 Column Settings

You can open this dialog from the menubar with Vocabulary → Column Settings...
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Use this dialog to define the column titles, keyboard layouts and widths of the vocabulary. Select
OK to make your changes or Cancel to discard any changes.

10.7 Special Characters

Click the Character... button on the Special Characters page in KWordQuiz settings dialog to
open this window.

Use this dialog to select any special character you want to associate with the current special
character action.
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Chapter 11

Credits and License

KWordQuiz

Program copyright 2003-2008 Peter B. Hedlund peter.hedlund@kdemail.net

Documentation copyright 2003-2008 Peter B. Hedlund peter.hedlund@kdemail.net

This documentation is licensed under the terms of the GNU Free Documentation License.
This program is licensed under the terms of the GNU General Public License.
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